PDA

Volledige versie bekijken : [Trage overdracht] SD Kaartje plotseling ontzettend traag



Alex_en_Iris
19 mei 2016, 13:52
Van het ene op het andere moment, tijdens het kopiėren van een groot aantal foto's en een paar video's naar de computer stortte de overdrachtssnelheid van 25 megabyte per seconde in naar 1,16.
Het kopiėren van de volledige inhoud van het kaartje heeft dan ook zo'n 6 uur geduurd.

Ik dacht eerst dat de interne SD-kaartlezer van de computer (ik heb een laptop) misschien per ongeluk op USB 1.1 stond te draaien, maar de poort geeft aan gewoon de volledige overdrachtssnelheid te gebruiken (ik ga even uit van USB 2.0, maar weet niet zo goed hoe de lezer intern verbonden is).
Een externe kaartlezer doet het overigens prima.

Naar het kaartje schrijven in de camera gaat prima, zelfs video opnemen gaat goed, het is echt puur het kopiėren dat niet lekker gaat.

Ik gebruik Windows 7 64-bit Professional, heeft iemand een idee waar ik het probleem moet zoeken?

[Edit] Voor iemand met de suggestie komt de computer uit te schakelen en weer te starten, dat heb ik al geprobeerd, dat helpt niet. :)

lucvr
19 mei 2016, 14:29
Ik heb ook regelmatig gelijkaardige problemen. Ook bij het copieren van de ene externe harde schijf naar de andere.
De snelheid gaat eerst normaal en dan valt dat terug op een tiende van de snelheid. En ik heb dat met meerdere computers voor. Zowel in Windows 7 als in Windows 10

Ik denk dat het gewoon aan windows ligt:confused:

Alex_en_Iris
19 mei 2016, 14:41
Linux, dat ik op die laptop soms wel in een live omgeving gebruik (USB stickje) vertoond overigens hetzelfde probleem, ik heb dat net even geprobeerd.

Tonerider
19 mei 2016, 14:50
en worden er op dat moment ook usb-poorten gebruikt?
nieuwste drivers geļnstalleerd (zo ja, verwijder deze en installeer de originele; zo nee, installeer deze).
Heeft hij het ook met andere kaartjes?

En soms gaat natuurlijk iets gewoon ook kapot.

Tonerider
19 mei 2016, 14:57
Ik heb ook regelmatig gelijkaardige problemen. Ook bij het copieren van de ene externe harde schijf naar de andere.
De snelheid gaat eerst normaal en dan valt dat terug op een tiende van de snelheid. En ik heb dat met meerdere computers voor. Zowel in Windows 7 als in Windows 10

Ik denk dat het gewoon aan windows ligt:confused:
USB is a shared bus technology, dus das dan logisch dat het boeltje vertraagt. Extern naar intern zou niets mogen geven echter.
Dus het ligt niet aan de software, wel aan de hardware.

Alex_en_Iris
19 mei 2016, 16:33
Er worden op dat moment zeker USB poorten gebruikt, maar ik weet niet of dat uitmaakt, aangezien het om een interne SD-kaartlezer gaat.
De USB poort die in gebruik is is die van mijn dataschijf (ik bewaar mijn foto's niet op mijn laptop, maar op een externe schijf) waar de hele boel naar toe gekopieerd wordt.

Helaas weet ik niet (ondanks dat ik de laptop al een paar keer tot op het moederbord uit elkaar heb gehaald voor het schoonmaken ervan) hoe de verbinding met het moederbord geregeld is.
De overdrachtssnelheid die ik ooit haalde komt trouwens overeen met de specificaties van USB 2.0 (de laptop komt uit 2011).

Zojuist heb ik trouwens een ander kaartje geprobeerd in dezelfde kaartlezer, dat gaat wel goed.
Ik dacht ook nog even dat het misschien iets te maken had met schrijfruimte (let op de extra R :P), aangezien het kaartje bijna vol was, maar met 1 GB vrij wordt de overdrachtssnelheid ook niet hoger.

Omdat ik nog garantie op de kaart heb denk ik dat ik deze eens binnenbreng bij de fotozaak.

Tonerider
19 mei 2016, 16:48
Er worden op dat moment zeker USB poorten gebruikt, maar ik weet niet of dat uitmaakt, aangezien het om een interne SD-kaartlezer gaat.
De USB poort die in gebruik is is die van mijn dataschijf (ik bewaar mijn foto's niet op mijn laptop, maar op een externe schijf) waar de hele boel naar toe gekopieerd wordt.

Helaas weet ik niet (ondanks dat ik de laptop al een paar keer tot op het moederbord uit elkaar heb gehaald voor het schoonmaken ervan) hoe de verbinding met het moederbord geregeld is.
De overdrachtssnelheid die ik ooit haalde komt trouwens overeen met de specificaties van USB 2.0 (de laptop komt uit 2011).

Zojuist heb ik trouwens een ander kaartje geprobeerd in dezelfde kaartlezer, dat gaat wel goed.
Ik dacht ook nog even dat het misschien iets te maken had met schrijfruimte (let op de extra R :P), aangezien het kaartje bijna vol was, maar met 1 GB vrij wordt de overdrachtssnelheid ook niet hoger.

Omdat ik nog garantie op de kaart heb denk ik dat ik deze eens binnenbreng bij de fotozaak.meestal zit de interne kaartlezer ook op de usb-hub en dan maakt het wel degelijk uit of er een andere 'zwaardere' zaken, zoals externe hdd aan uw usb hangen .

Maar als een andere kaart wel werkt dan is het dus niet de usb verbinding.

Black B@ndit
19 mei 2016, 19:06
Het zou misschien ook aan de ingebouwde kaartlezer kunnen liggen?
Een slechte verbinding tussen het geheugenkaartje en de kaartlezer kan ook voor problemen zorgen.
Als een van de contactjes niet goed doorgeeft, dan zou het misschien mogelijk zijn dat de datatransfer een stuk trager gebeurt.
Je zou het geheugenkaartje dus ook eens kunnen testen in een externe geheugenkaartlezer (of de camera aansluiten op de laptop, en zo de data overzetten), dan weet je of het aan het kaartje zelf ligt, of aan de geheugenkaartlezer.

Ik heb net nog een probleem gehad met een externe USB3 kaartlezer die een slechte verbinding heeft, de USB aansluiting op de geheugenkaartlezer zelf geeft niet altijd goed contact (stekkerverbinding voor de kabel naar de pc).
Bij de minste beweging van de kabel hoor ik het geluidje om aan te geven dat er iets aangesloten wordt op de pc.
Eerst heb ik een andere kabel geprobeerd, maar het probleem blijft, daarom durf ik die Hama geheugenkaartlezer niet meer te gebruiken, en gebruik ik terug de oude Sandisk geheugenkaartlezer die veel trager is (ik heb een nieuwe Sandisk USB3 geheugenkaartlezer besteld).
Spijtig genoeg heb ik het aankoopbewijs van die Hama geheugenkaartlezer niet meer, want die is normaalgezien nog wel in garantie...(die was niet zo duur, maar ik had wel verwacht dat die langer heel zou blijven)

Alex_en_Iris
20 mei 2016, 11:17
Dezelfde kaart vertoond in een externe kaartlezer dezelfde problemen, maar de contacten zijn, voor zo ver ik kan zien niet zo vuil dat deze het contact zouden bemoeilijken.
Wat ik niet zo goed begrijp (en ergens ook weer wel) is waarom naar de kaart schrijven in de camera zonder problemen verloopt en lezen zo'n probleem is (en waarom ik het dus wel begrijp: een van de twee is altijd sneller en heeft minder last van bepaalde bandbreedte beperkingen).

Black B@ndit, dat klinkt als een breuk van een soldeereiland bij de connector.

[Edit] Ik voel mij nu een beetje stom. Zojuist even de tijd genomen om de kaartinhoud naar de computer te kopiėren en de kaart te formatteren in de camera. Dat heeft het probleem opgelost. Hier kan dus een slotje op, of wat er dan ook gebruikelijk is om hier te roepen.